Alan’s Top Excel Tips

Session 1

After Microsoft developed Excel to the 2010 version, it offered more surprises than ever. In order to deal
with tons of big data, you can’t ignore the important role Excel plays in daily work. However, both for
beginners and advanced users, there are still many useful tips and tricks that are inevitably overlooked. In
my 2020 Excel webinars I am going to share many of them with you
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1.AutoSum

AutoSum can save a number of repetitive steps for those working with a range of numbers. If, for
example, you would like to add a range of numbers, you need only to place the cursor in a cell at or near
the end of the range and double click on the AutoSum icon to capture the sum.

2. One Click to Select All

You might know how to select all by using the Ctrl + A shortcut, but few know that with only one click of
the corner button, as shown in the screenshot below, all data will be selected in seconds.
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3. Open Excel Files in Bulk

Rather than open files one by one when you have multiple files you need to handle, there is a handy way
to open them all with one click. Select the files you would like to open then press the Enter key on the
keyboard, all files will open simultaneously.
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4. Shift Between Different Excel Files

When you have different spreadsheets open, it’s really annoying shifting between different files because
sometimes working on the wrong sheet can ruin the whole project. Using Ctrl + Tab you can shift
between different files freely. This function is also applicable to other files like different Windows tabs in
Firefox when opened using Windows 7.

5. Speedily Move and Copy Data in Cells

If you want to move one column of data in a spreadsheet, the fast way is to choose it and move the pointer
to the border, after it turns to a crossed arrow icon, drag to move the column freely. What if you want to
copy the data? You can press the Ctrl button before you drag to move; the new column will copy all the
selected data.
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6. Speedily Delete Blank Cells

Some default data will be blank, for various reasons. If you need to delete these to maintain
accuracy, especially when calculating the average value, the speedy way is to filter out all blank
cells and delete them with one click. Choose the column you want to filter, go to Data->Filter,
after the downward button shows, undo Select All and then pick up the last option, Blanks. All
blank cells will show immediately. Go back to Home and click Delete directly, all of them will
be removed.
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7. Fast Navigation with Ctrl + Arrow Button and the Mouse

When you click Ctrl + any arrow button on the keyboard, you can jump to the edge of the sheet in
different directions. If you want to jump to the bottom line of the data, just try to click Ctrl + downward
button.

ctrl

8. Hide Data Thoroughly

Almost all users know how to hide data by right clicking to select the Hide function, but this can be easily
noticed if there is only a little bit of data. The best and easiest way to hide data thoroughly is to use the
Format Cells function. Choose the area and go to Home->Font->Open Format Cells->Number Tab-
>Custom->Type ;;; -> Click OK, then all the values in the area will be invisible, and can only be found in
the preview area next to the Function button.
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9. Input Values Starting with 0

When an input value starts with zero, Excel will delete the zero by default. Rather than reset the Format
Cells, this problem can be easily solved by adding a single quote mark ahead of the first zero, as shown.
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10. Speed up Inputting Complicated Terms with AutoCorrect

If you need to repeat the same value and it is complicated to input, the best way is to use the AutoCorrect
function, which will replace your text with the correct text. Take my name, Liza Brown, for example,
which can be replaced by LZ. Therefore, every time I input LZ, it can autocorrect to Liza Brown. Go to
File->Options->Proofing->AutoCorrect Options and input Replace text with correct text in the red
rectangular area, as below.
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11. Conditional Formatting

Conditional formatting makes data easier to interpret because a cell’s value controls the appearance of
that cell. Conditional formats make analyzing data — spotting unusual observations, tracking trends,
checking status, and finding top values — easier and more effective. These formats are called conditional
formats because their application depends on whether the data meets the conditions you specify.

Conditional formatting has been a part of Excel functionality since Excel 97, but it has been enhanced
greatly over the years. Five types of conditional formats are available to apply to a cell or to a range of
cells.

Highlight Cells Rules — Rules are created to highlight cells when some criteria are met. There are seven
built-in rule types: Greater Than, Less Than, Between, Equal To, Text That Contains, A Date Occurring,
and Duplicate Values.

Top/Bottom Rules — Formatting is applied to a selected range of cells that are more or less than a given
threshold. There are six built-in rule types: Top N Items, Top N %, Bottom N Items, Bottom N %, Above
Average, and Below Average.

Data Bars — This fills cells with gradient bars whose length is relative to all other values in the selected
range. The color combinations available are dependent on the active theme.

Color Scales — This fills cells with gradient colors using a two- or three-color scheme. The shades are
relative to all other values in the selected range. The color combinations available are dependent on the
active theme.

Icon Sets — This fills the left-hand margin of cells with small graphic characters whose shape and color is
relative to all other values in the selected range.

To apply conditional formatting to a cell or range of cells, highlight the cells and then select Conditional
Formatting from the Home tab of the Ribbon. Select the conditional formatting type desired and fill out
any additional dialogs to complete the process. Monthly sales greater than $30,000 or those less than
$7,000 are highlighted in Figure 22. Two Highlight Cells rules produce the formatting.

Jan Feb Mar Apr May Jun Total
Creme, Aloe Vera Hand, 9 oz S 8388 $ 9,087 S 8039 S 838 S 10,485 S 12,582 $ 56,969
Creme, Extra Moisturizing Hand, 9 oz 8,988 9,737 8,614 8,988 11,235 13,482 61,044
Creme, Hand and Body, 16 oz 15,588 16,887 14,939 15,588 19,485 23,382 105,869
Lotion, Organic Body, 9 oz 9,588 10,387 9,189 9,588 11,985 14,382 65,119
Lotion, Organic Body, 16 oz 17,988 19,487 17,239 17,988 22,485 26,982 122,169
Lotion, Organic Body, 24 oz 26,388 28,587 25,289 26,388 32,985 39,582 179,219
Lotion, Extra Moisturizing Body, 9 oz 8,388 9,087 8,039 8,388 10,485 12,582 56,969
Lotion, Organic Hand and Body, 9 oz 10,188 11,037 9,764 10,188 12,735 15,282 69,194
Lotion, Organic Hand and Body, 16 oz 19,188 20,787 18,389 19,188 23,985 28,782 130,319
Mask, Organic Facial, 9 oz 16,788 18,187 16,089 16,788 20,985 25,182 114,019
Mask, Wrinkle Reducing Facial, 9 oz 22,788 24,687 21,839 22,788 28,485 34,182 154,769
Mask, Wrinkle Reducing Facial, 16 oz 5,399 4,679 4,139 4,319 5,399 6,478 30,413
Mask, Wrinkle Reducing Facial, 24 oz 8,099 7,019 6,209 6,479 8,099 9,718 45,623

As shown in Figure 22, multiple rules can be applied to the same range of cells. However, when a cell
meets the criteria of more than one rule, the rule highest in the Conditional Formatting Rules Manager
will prevail. As new conditional formatting rules are created, they are added to the top of the Rules



Manager list. The Rules Manager provides a single place to manage all rules for a selected range, the
active worksheet, or another sheet in the active workbook. To access the Rules Manager, select
Conditional Formatting, Manage Rules from the Home tab of the Ribbon.

The second example uses the same data but applies Color Scales to the sales totals to help you understand
the relative sales contribution of individual products as shown in Figure 23. The detail columns have
been hidden for presentation so that your focus is on total sales. In this case, the lowest sales volume is
colored in red, the highest volume is colored in green, and the median value is colored in yellow. All
other sales volumes are displayed in shades of these three colors to indicate their relative value.

Total
Creme, Aloe Vera Hand, 9 oz S 56,969
Creme, Extra Moisturizing Hand, 9 oz 61,044
Creme, Hand and Body, 16 oz 105,869
Lotion, Organic Body, 9 oz 65,119
Lotion, Organic Body, 16 0z 122,169
Lotion, Organic Body, 24 oz 179,219
Lotion, Extra Moisturizing Body, 9 oz 56,969
Lotion, Organic Hand and Body, 9 oz 69,194
Lotion, Organic Hand and Body, 16 oz 130,319
Mask, Organic Facial, 9 oz 114,019
Mask, Wrinkle Reducing Facial, 9 oz 154,769
Mask, Wrinkle Reducing Facial, 16 oz 30,413
Mask, Wrinkle Reducing Facial, 24 oz 45,623

Figure 1 - Better Information Presentation Using Color Scales

A similar result can be produced using Data Bars or Icon Sets as shown in Figure 24. There are a large
number of built-in icon sets. Rule thresholds for icon sets and color scales can be adjusted through the
Rules Manager. Both data bars and icon sets can be displayed with or without values.

Total Total
Creme, Aloe Vera Hand, 9 oz S | 56,969 Creme, Aloe Vera Hand, 9 oz ) S 56,969
Creme, Extra Moisturizing Hand, 9 oz 61,044 Creme, Extra Moisturizing Hand, 90z (5} 61,044
Creme, Hand and Body, 16 oz 105,869  Creme, Hand and Body, 16 oz (1) 105,869
Lotion, Organic Body, 9 oz 65,119 Lotion, Organic Body, 9 oz & 65,119
Lotion, Organic Body, 16 oz 122,169 Lotion, Organic Body, 16 oz (0 122,169
Lotion, Organic Body, 24 oz 179,219 Lotion, Organic Body, 24 oz @ 179,219
Lotion, Extra Moisturizing Body, 9 oz 56,969 Lotion, Extra Moisturizing Body, 90z ) 56,969
Lotion, Organic Hand and Body, 9 oz 69,194 Lotion, Organic Hand and Bedy, 90z (&) 69,194
Lotion, Organic Hand and Body, 16 oz 130,319 Lotion, Organic Hand and Body, 16 0z & 130,319
Mask, Organic Facial, 9 oz 114,019 Mask, Organic Facial, 9 oz (0 114,019
Mask, Wrinkle Reducing Facial, 9 oz 154,769 Mask, Wrinkle Reducing Facial, 90z @ 154,769
Mask, Wrinkle Reducing Facial, 16 oz 30,413 Mask, Wrinkle Reducing Facial, 16 0z (&) 30,413
Mask, Wrinkle Reducing Facial, 24 oz 45,623 Mask, Wrinkle Reducing Facial, 240z (&) 45,623

Figure 2 - Conditional Formatting Using Data Bars and Icon Sets



The Highlight Cells rules are the only rules that operate independently on each
cell formatted with the condition. The other rule types format cells relative to
the values of the other cells in the range formatted. For example, the length of
data bars is relative to the largest value in the range formatted with the
condition. If a range is expanded to include a larger value, the length of the data
bars in the entire range will change.

®

The last example of conditional formatting will use a formula to apply formatting to accounts whose
variances are greater than 10% of budget. The condition will be applied to the complete report table so
that the entire row for each account meeting the condition will be highlighted in color. Figure 25 displays
the finished report along with the conditions set in the New Formatting Rule dialog box.

A B C D E
1 Larry's Landscaping Services
2 Actual to Budget Performance
Select a Rule Type: 3
= Format all cells based on their values ~ Budget _Actual Variance
= Farmat only cells that contain 5 6230 Auto Fuel $ 150 3 19 5 (]
~ Format only top or bottom ranked values L 6240 Auto Maintenance 0 32 2
~ Format only values that are above or below average U 6400 Bank Service Charges = 2 .
~ Format only unique or duplicate values 8 6550 Payroll Expenses 9,400 9,700 300
= Use a formula to determine which cells to format = 6600 Delivery Fee 1,000 %0 (20
10 6900 Insurance 250 250 -
Edit the Rule Description: n 7100 Equipment Rental - 373 375
12 7200 Miscellaneous 100 263 163
Format values where this formula is true: 13 7300 Office Supplies 50 41 (9)
=ABS(SES/5C5)>=.1 ES—E 14 7500 Rent 2,000 2,000 -
15 7553 Equipment Repairs - 176 176
16 7700 Tools and Miscellaneous Equipment 150 133 (17)
17 7751 Gas and Electric 250 228 (22)
Preview: AaBbCcYyZz Eormat... 18 7753 Telephone 50 51 1
19 7752 Water 75 i (1)
oK Cancel 20 9000 Interest Expense 350 345 (5)
21
22 Total 513,900 515042 5 1,142

Figure 3 - Conditional Formatting by Formula

To create the formatting rule, follow these six steps.

L.

6.

Highlight the range on which the conditional formatting will apply. In this case, highlight the range
A5:E20.

From the Ribbon, select Home, Conditional Formatting, New Rule.

In the New Formatting Rule dialog box, select Use a formula to determine which cells to
format.

Enter the following formula in the formula box.

=ABS($E5/$C5)>=0.1

Click the Format... button and choose the desired format to be applied to the selected cells when
the criterion specified in the formula is met. Click OK.

Click OK to format the report.

All rows associated with absolute values of variances that are greater than 10% of budget are now
highlighted in the report.



@ A bit of caution is advisable when using conditional formatting. Not all users of
the report may not be knowledgeable about formulas that control the
formatting. For example, a person simply looking at the results in Figure 25
has no way of knowing the rule that created the yellow lines is based on 10%
variances. Therefore, it may be a good practice to include an explanation or
legend of what the conditional formatting reveals.

12. Using Slicers to Filter PivotTables

Think of Slicers, added to PivotTables with the 2010 release of Excel and to tables with the 2013 release

of Excel, as end-user filters. Slicers allow you to filter data in a PivotTable, PivotChart, or table by

clicking on buttons that represent one or more dimensions in a data set. You can resize and format these
filtering windows like charts or other shapes in Excel. You can insert a Slicer by selecting any PivotTable
or PivotChart and then selecting Insert Slicer from the PivotTable Tools, Analyze contextual tab of the
Ribbon. By selecting the PivotTable or PivotChart first, the two objects will be associated with each other

automatically.
PivotTable Tools
Analyze
=2 Group Selection Insert Slicer | D D [7 Clear~ [7 Fields, ltems, & Sets~
28 Ungroup 5 Insert Timeline e [T} Select ~ OLAP Tools
Refresh Change Data
Group Field FE Filter Connections = Source * [(3 Move PivotTable Relationships
Groug Filter Data Adions Calculations

1 || Region = Sales Revenue

2 y : Grand Total
2 Astringent, Organic, 16 oz 27,017 33,686 43,758 32,875 137,336
4 Southeast Astringent, Organic, 24 oz 51,963 65,005 83,574 63,719 264,261
5 Midwest Astringent, Organic, 32 oz 77,639 96,417 124,063 94,763 392,882
6 Astringent, Organic, 48 oz 25,496 31,439 40,396 30,856 128,187
7 West Cream, Aloe Vera Hand, 9 oz 28,483 34,739 45,253 34,231 142,706
8 Cream, Extra Moisturizing Hand, 9 oz 30,810 37,490 49,026 37,388 154,714
9 Years = X Cream, Hand and Body, 16 oz 53,172 64,826 84,583 64,565 267,146
10 Lotion, Extra Moisturizing Body, 9 oz 28,217 34,925 45,055 34,448 142, 645
11 2016 " Lotion, Organic Body, 16 oz 60,188 74,445 97,200 73,410 305,247
12 Lotion, Organic Body, 24 oz 88,277 109,109 142,454 107,908 447,788
13 Lotion, Organic Body, 9 oz 32,649 40,040 52,311 39,619 164,619
14| 2018 ¥ | Lotion, OrganicHand and Body, 160z 65,098 80,651 103,833 78,895 228,477
15 Lotion, Organic Hand and Body, 9 0z 34,231 42,307 54,847 41,812 173,197
16 Mask, Organic Facial, 9 oz 56,158 69,525 90,048 69,116 284,847
17 Mask, Wrinkle Reducing Facial, 16 oz 15,776 17,838 23,175 17,891 74,680
18 Mask, Wrinkle Reducing Facial, 24 oz 23,885 27,106 35,293 27,061 113,345
19 Mask, Wrinkle Reducing Facial, 9 oz 77,269 94,795 124,471 94,814 391,349
20 Scrub, Hypo-Allergenic, 16 oz 26,780 33,001 43,509 32,731 136,021
21 Scrub, Hypo-Allergenic, 24 oz 47,483 58,701 76,858 57,822 240,864
22 Scrub, Hypo-Allergenic, 9 oz 24,050 29,997 38,958 29,270 122,275
23 Grand Total 874,641 1,076,046 1,398,705 1,063,194 4,412,586

The items in each Slicer are colored when selected as shown in Figure 208 and function similarly to the
drop-down menus used to filter rows, columns, and report filters within a PivotTable. To clear filters and

Figure 4 - Slicers Provide Visual Filtering in Excel 2010 and Newer

display all values in a PivotTable or PivotChart, click the Clear Filter icon in the Slicer's header.




Additionally, you can associate a single Slicer with multiple PivotTables by manipulating the Report
Connections settings from the Slicer Tools Options tab on the Ribbon.

If you use Excel 2013 or newer, you can use Slicers to filter tables. To add one or more Slicers to a table,
begin by clicking in the table. Next, choose Insert Slicer from either the Insert tab of the Ribbon or from
the Table Tools Design tab of the Ribbon. Finally, choose the field(s) you want to filter with your Slicer
and click OK to complete the process. As with Slicers applied to PivotTables, just click on the item(s) in
the Slicer filter you want to use as your filter, and your table applies the filter immediately.
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