











Excel Magic
The Road to Excellence


[image: ]


[bookmark: _GoBack]One of the most time-consuming tasks faced by those who create analyses in Microsoft Excel is the assembly and printing of reports. This session is devoted to helping you be more effective and efficient in the report assembly and printing process. 
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[bookmark: Excel_Using_the_Accounting_Format]Printing Essentials
One of the most time-consuming tasks faced by those who create analyses in Microsoft Excel is the assembly and printing of reports. This session is devoted to helping you be more effective and efficient in the report assembly and printing process. Some of the topics to be covered include report integration using embedded or linked objects, creating dynamic print areas using Custom Views, using the Camera to create report forms, and assembling views and report forms into integrated reports using Report Manager.

[bookmark: Learning_Objectives][bookmark: _bookmark223][bookmark: Review_of_Printing_Basics][bookmark: _bookmark224]Review of Printing Basics
First, all print settings are available from the Page Layout tab of the Ribbon as shown in Figure 1. Most users should be able to set printing preferences in the Page Setup dialog box, print individual worksheets or parts of worksheets, and set page orientation, margins, and headers and footers. Beyond these few basic skills, many printing processes and settings are unknown or confusing to many Excel users. Let's examine a few processes and settings that can ease the burden of printing financial analyses and reports.
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[bookmark: _bookmark225]Figure 1 - Page Layout Tab of the Ribbon

[bookmark: Setting_Margins_and_Page_Orientation][bookmark: _bookmark226][image: ]Setting Margins and Page Orientation
[bookmark: _bookmark227]To set the margins, page orientation, paper size, print area, page breaks, or repeating rows or columns, select the appropriate option from the Page Setup group on the Page Layout tab of the Ribbon as shown in Figure 2.Figure 2 - Basic Print Settings Exposed on the Page Layout Tab of the Ribbon
There are a number of predefined margin settings that can be applied with a single click of the mouse. Custom margins can be entered by clicking on Custom Margins. Note that the predefined margin setting for the Last Custom Setting will be redefined to be consistent with the last custom margin used. The familiar Page Setup dialog box is accessible from the dialog launcher located in the lower right-hand corner of the Page Setup group.

[bookmark: Adjusting_Page_Size_and_Page_Number][bookmark: _bookmark228]Adjusting Page Size and Page Number
Nearly everyone has used the scaling options, commonly referred to as "shrink to fit" to re-size printed output to the actual paper size. In default, selecting the option shrinks the output horizontally and vertically. However, we often have long reports that are only slightly wider than a defined page. In those instances, the report needs to be shrunk horizontally while allowing the report to run out as many pages as necessary to print the entire document. In other words, the page width needs to be shrunk without affecting the length of the printed document. The problem is that the settings are adjusted through spinner controls as shown in Figure 3. Seemingly, one must adjust the vertical control using trial and error until the document is sized to print properly. However, here is a trick to circumvent that entire process. Just delete the spinner page setting for the number of pages tall (long) that the printout is to be! Once that is done, the document's width will be adjusted to fit the page and margin settings while allowing the entire document to print. The process shrinks a document for printing horizontally without shrinking it vertically.
[image: ]
[bookmark: _bookmark229]Figure 3 - Shrinking a Printout Horizontally and Setting the Page Number

To delete the vertical (tall) page size, put your cursor in the size box and press Delete. Also, note in Figure 138 the First page number field in the Page Setup dialog box for setting the page number of the first printed page. Being able to set the page number is useful when a report is composed of printouts from several Excel workbooks or worksheets or a combination of Excel workbooks and Word documents.
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[bookmark: Making_Printing_Easier_with_Sheet_Settin][bookmark: _bookmark230]Making Printing Easier with Sheet Settings
On the Sheet tab of the Page Setup dialog box, accessible by clicking Print Titles on the Page Layout tab of the Ribbon, are several settings that can make printing complex documents easier. For example, if headings need to be printed on each page, a way to handle that would be to put the headings in a Custom Header. However, most accounting professionals routinely include their headings at the top of their worksheets, which may cause printing problems if the user does not know how to make the headings repeat on each page. A similar issue may arise when printing a multiyear cash flow analysis for a capital project where a user may want to print repetitively the column on the left that identifies the contents of each row. To accomplish these tasks, set the Rows to repeat at top or Columns to repeat at left in the Print Titles area of the Sheet tab in the Page Setup dialog box.

In our example, displayed in Figure 4, you might want to print the headings at the top of each page of the notes to accompany compiled financial statements. Note that rows one through five, which include the three-line heading plus the two blank spacer rows, are specified as the Rows to repeat at top. More importantly, the Print area, rows six through eighty-three, does not overlap the rows to repeat. Overlapping the print area with the rows or columns repeated, which causes double printing of the repeated rows or columns, is a common mistake made by many users.
[image: ]

[bookmark: _bookmark231]Figure 4- Advanced Print Settings on the Sheet Tab

Also on the Sheet tab are settings to control the printing of comments and cell errors. In default, comments are not printed, but they can be printed 1) as displayed on the sheet or 2) at the end
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of the sheet. For example, you may enter comments in the master budget workbook during the budgeting process. In preparing for an upcoming budget status meeting, you want to print all relevant comments. To accomplish this task, display and arrange the comments as desired and then print the workbook with comments set to be printed as displayed. Only the comments displayed will print, and they will print as they have been arranged on the worksheet. Comments may be added, deleted, hidden, or displayed from the context-sensitive menu or from the Review tab of the Ribbon.

Cell errors can also be a problem on printed reports. For example, some calculations may cause the #DIV/0 error in a worksheet. These errors are especially prevalent in worksheets that present variances and variance percentages. Any variance percentage calculated where the budgeted amount was zero for the period will yield the error. The most common solution to this problem is to type over the formula so that the error does not appear on the printed report. Of course, that solution corrupts the worksheet so that it does not calculate properly in the future.

A better solution is to use a more complex formula to calculate the variance percentage. The formula would use the IF function to test whether the divisor is equal to zero, and if it is, then it will return a null string, which displays a blank cell, as discussed earlier in Chapter Four.

A third solution is to leave the errors intact on the worksheet but choose to print the worksheet with settings that hide them on the printed report. In default, cell errors print as displayed on the worksheet. However, errors may be printed as 1) blank cells, 2) dashes (--), or 3) #N/A. To hide cell errors on a printed report, simply select <blank> in the Cell error as drop-down box on the Sheet tab of the Page Setup dialog box.

[bookmark: Applying_Page_Settings_to_Multiple_Works][bookmark: _bookmark232]Applying Page Settings to Multiple Worksheets
One of the most frequent questions asked of K2E Canada Inc. instructors is how to apply page settings to multiple worksheets at the same time. To apply page settings such as headers and footers to multiple worksheets simultaneously, group or activate the appropriate sheets and then set the appropriate page settings. To group multiple sheets, hold the CTRL key down while clicking the tabs of the worksheets to which you want to apply the same page settings. The tabs of grouped worksheets will be highlighted when selected as shown in Figure 5.
[image: ]
[bookmark: _bookmark233]Figure 5 - Grouped Sheets Having Highlighted Tabs


When worksheets are grouped, any page setting configured will apply to all sheets. In other words, to set headers and footers on multiple worksheets at one time, first group the sheets before entering the headers and footers.

The page settings of an existing worksheet can be applied or transferred to other worksheets in the same workbook. However, the worksheet that contains the settings that you want to transfer must be selected first in the grouping process as previously described. Simply select the desired worksheets, making sure to select first the worksheet that contains the page settings to be transferred. Now, from the Ribbon, choose Page Layout, click the dialog launcher in the Page Setup group, and then click OK. It is as simple as that! The page settings on a worksheet in another workbook can be transferred similarly by first dragging a copy of the worksheet into the current workbook, going through the page setting transfer steps described, and then deleting the imported worksheet. Note that all print settings are transferred by this method.

[bookmark: Setting_Print_Areas][bookmark: _bookmark234]Setting Print Areas
Most accounting practitioners understand that they can print part of a worksheet by setting a Print Area to include just that part of the worksheet they wish to print. However, a Print Area need not be set to accomplish this task. Simply highlight the range to be printed and then click the File tab, Print, and under Settings, choose Print Selection as shown in Figure 6.
[image: ]

[bookmark: _bookmark235]Figure 6 - Printing a Selection in Excel 2013/2016
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This is ideal for printing what could otherwise be termed temporary print areas. Of course, if the same area is always printed, then setting a Print Area is a more efficient way of printing.

In Excel 2007, from the Office Button, select Print. Choose Selection in the Print what section in the lower left corner of the Print dialog box and click OK as shown in Figure 7.


[bookmark: _bookmark236]Figure 7 - Printing a Range without Setting a Print Area in Excel 2007

Likewise, you can print multiple non-contiguous print areas using the same technique. Use CTRL + Click and Drag to highlight multiple non-contiguous print areas. Again, select Print, choose Selection, and then click OK. Not only does this technique print the areas selected, but it also prints them in the order selected. That means that you can print an area near the bottom of a large worksheet before an area at the top by selecting the bottom area first! Note, however, that each selection prints on a separate page. If the selections are to be printed on a single page, a report form will have to be created. Report forms are covered later in this chapter.

Suppose that each time you print a particular worksheet, you want the same three print areas printed in a specific order. The proper way to accomplish this task is to set three non-contiguous print areas in the worksheet. First, highlight and set the first area to be printed. From the Page Layout tab of the Ribbon, select Print Area, Set Print Area. Then, highlight and set additional print areas, one at a time, in print order. For these additional areas, select Print Area, Add to Print Area from the Page Layout tab of the Ribbon.


	
	In earlier versions of Excel, multiple non-contiguous print areas could not be created in a serial process, one after another, because the creation of subsequent print areas destroys existing print areas. The trick is to first define all of the print areas (in the order in which they are to be printed) using the CTRL + Click and Drag process and then to choose Set Print Area from the File menu.



[bookmark: Printing_Multiple_Worksheets][bookmark: _bookmark237]Printing Multiple Worksheets
Just as multiple print areas can be printed with a single print command, so can multiple sheets or an entire workbook be printed. To print multiple worksheets, group the worksheets to be printed using the process described earlier and then click the Quick Print button on the QAT or select Print from the File tab in Excel 2010 and later or the Office Button in Excel 2007. Note that the worksheets always print in sheet tab order from left to right, regardless of the order in which the sheet tabs were selected. This is different from the order in which multiple print areas are printed. As we discovered earlier, multiple print areas print in the order selected. If the worksheet tabs are not in the proper print order, drag the worksheet to the appropriate location, then select and print the sheets desired.

You can print an entire workbook in one of two ways. The first is to group all sheets and click the Quick Print command on the QAT or select Print from the File tab in Excel 2010 or newer or the Office Button in Excel 2007. The second option is, with the worksheets ungrouped, to select Print from the File tab and, under Settings, choose Print Entire Workbook. If you use Excel 2007, you can perform this sequence clicking the Office Button. Then, in the Print dialog box, select Entire workbook in the Print what section. Click OK to print the entire workbook.

Printing multiple grouped workbooks with a single command has a hidden advantage – the entire printout is consecutively paginated. Suppose that we printed three four-page worksheets with separate print commands. Each of the four page printed reports would be paginated one through four. If we had grouped all three worksheets and printed them with a single command, the printed reports would be paginated one through twelve. This functionality provides you with additional flexibility in paginating reports printed from multiple worksheets.

	
	Caution! When you act on grouped worksheets, any action taken on one worksheet is replicated on all others in the group. This can be very dangerous if you inadvertently save a workbook with grouped sheets because Excel will open the workbook the next time it is used with the worksheets still grouped. While working on one sheet, you or a coworker will be destroying the others. The only telltales that worksheets in a workbook are grouped are 1) the visual cue "[Group]" appears in the title bar of the window in which the workbook is opened, and 2) multiple worksheet tabs will be highlighted. Both telltales are not very prominent and are easy to overlook. You must be disciplined in your use of worksheet grouping. When you want to take action on a group of worksheets, you must group the sheets, take the desired action, and then immediately ungroup the sheets. Otherwise, danger lurks!




[bookmark: Setting_Page_Breaks][bookmark: _bookmark238]Setting Page Breaks
Quite often, the default page breaks in a report or analysis do not divide the document properly for printing. For example, an accountant may want to produce a two-page balance sheet with assets printed on the first page and liabilities and equities printed on the second. If the worksheet is not laid out to conform to the desired print layout, some of the liabilities and equities section of the balance sheet may be printed on the first page where the asset section is presented. To avoid this result, add page breaks to the worksheet in the locations desired or use Page Break Preview to drag-and-drop the page breaks to the proper location. A fine, dashed line indicates default page breaks, while user-set page breaks (including print areas) are indicated by a coarse dashed line. The horizontal page break shown in Figure 8 is a default page break, denoted by the fine dashed line, while a user has set the vertical page break.
[image: ]

[bookmark: _bookmark239]Figure 8 - Page Breaks as Shown in Normal and Page Break Preview

In new worksheets that have never been printed, the default page breaks do not appear. To display the default page breaks without printing the worksheet, simply click the Print Preview command on the QAT. When the Print Preview window is closed, the default page breaks will appear. To set a manual page break, position the cursor in a cell immediately below the row and/or immediately to the right of the column where you want to insert the page break as shown in Figure 9. Then, from the Page Layout tab of the Ribbon, select Breaks, Insert Page Break.




[image: ]

[bookmark: _bookmark240]Figure 9 - Manually Setting a Page Break

Page breaks may also be set to the proper location using drag-and-drop within the Page Break Preview, accessible from the View tab of the Ribbon, or by clicking the Page Break Preview icon on the Status Bar just to the left of the Zoom Slider as shown in Figure 10.
[image: ]

[bookmark: _bookmark241]Figure 10 - Using Page Break Preview to Drag-and-drop Page Breaks

[bookmark: Page_Layout_View_and_Headers/Footers][bookmark: _bookmark242]Page Layout View and Headers/Footers
You can add headers and footers in the conventional manner within the Page Setup dialog box discussed earlier in this chapter. A better way of adding headers and footers to a worksheet is to use the Page Layout view. The Page Layout view in Excel provides similar functionality to the Print Layout view in Word. It provides a view of how the worksheet or defined print area will print on a page-by-page basis. You can enable Page Layout view by selecting Page Layout from the View tab of the Ribbon or by clicking the Page Layout icon on the Status Bar just to the left of the Zoom Slider as shown in Figure 146.

In Page Layout view, headers and footers can be seen at the top and bottom of each page. The header and footer areas are clickable, each with three sections – one each for the left, center, and right headers/footers – similar to the layout in the Page Setup dialog box. Headers and footers can be entered directly into the worksheet by clicking and typing into the appropriate sections. When you click into a header or footer section, the Header & Footer Tools contextual tab appears in the Ribbon, from which page numbers and other functions can be entered as shown in Figure 11. Note the advanced capabilities, such as Different First Page, Different Odd and Even Pages, and Scale with Document.
[image: ]
[bookmark: _bookmark243]Figure 11 - Entering Headers and Footers in Page Layout View

[bookmark: Adding_Print_Tools_to_the_Ribbon_and_Qui][bookmark: _bookmark244]Adding Print Tools to the Ribbon and Quick Access Toolbar 
Let us make two modifications to the Ribbon (Excel 2010 or newer) and/or the QAT (Excel 2007 or newer) to make printing and working with print areas easier and faster. First, add the Print Area icon to the Ribbon, the QAT, or both. Next, add the Print icon to the Ribbon, the QAT, or both.

Additionally, the QAT is easily configured with the Quick Print command, which sends the print job immediately to the default printer. Just click on the drop-down arrow at the far right end of the QAT and select Quick Print. If you want to print a selection without setting a print area or want to change the printer, the Quick Print command does not accommodate these actions. In those situations, you must select Print to get the full Print dialog from which these changes can be made. If print settings are changed often at print time, then it may be advantageous to add the Print command to the QAT.

[bookmark: Using_the_Camera_to_Create_Report_Forms][bookmark: _bookmark245]
Using the Camera to Create Report Forms
Earlier we learned how to set multiple print areas in the same worksheet. Creating print areas as we described causes them to print on separate pages in the order selected. Quite often, users would like the several print areas to print on the same page in a specific layout. In other words, their report is made up of multiple small snippets of a workbook arranged on a single page. We refer to the resulting printable sheet as a report form. Those faced with the task of building reports in this fashion understand the difficulty of achieving this result. Cutting and pasting doesn't work because the column widths of the individual snippets vary, so the report doesn't line up properly. Further, cutting and pasting results in static reports that require a repeat of the process when the underlying data changes. Building formulas to bring live data to a report print area is a better solution, but the process is time-consuming and cumbersome, and there is no guarantee that the data will line up any better than with cutting and pasting.

That brings us to the Camera tool. The Camera allows you to cut and paste dynamic pictures of data ranges that can then be arranged in any layout for display or printing. To use the Camera, first add the tool to the QAT. Just click on the drop-down arrow at the far right end of the QAT and select More Commands. In the Excel Options dialog box, select Commands Not in the Ribbon. Scroll down in the list of commands and select the Camera tool. Click Add and then OK to close the dialog box as shown in Figure 13.

[image: ]

[bookmark: _bookmark246]Figure 13 - Adding the Camera to the QAT

The use of the Camera is very similar in operation to cut and paste. Highlight the range to copy and click the Camera toolbar button. Now, navigate to the worksheet that will serve as your report form and click with your mouse on the sheet. A picture of your data snippet will be pasted on the worksheet. Click and drag the picture to its proper location. Repeat the process with other data snippets to build your report form as shown in Figure 13.

[image: ]

[bookmark: _bookmark247]Figure 14 - Assembling a Report Form Using the Camera

The report form in Figure 14 was produced from three different worksheets within the same workbook. Notice how the columns of each snippet remain intact as originally formatted. This formatting is impossible to produce using conventional cut and paste techniques. Moreover, these snippets have hidden power! Each one links to the underlying data from which it was copied so that as the original data is updated, the report form is updated, providing us with flow- through reporting. If the snippet is not to be updated when its underlying data changes, copy the area using the Paste, As Picture, Copy as Picture command from the Home tab of the Ribbon. Then, paste it in the desired location with Paste, As Picture, Paste as Picture command.

When pasted, a black border surrounds each snippet on the report form. To remove the border, right-click on the snippet and select Format Picture. On the Colors and Lines tab, select No Lines in the Line Color drop-down box and click OK as shown in Figure 14. You can resize a picture by dragging its sides or corners, but dragging its corners reduces the likelihood of visual distortion.
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[bookmark: _bookmark248]Figure 14 - Selecting No Line to Remove the Border from Camera Snippets

The Camera tool works across multiple workbooks, and you can even paste linked snippets into Word documents. To insert a Camera worksheet snippet into a Word document, highlight and capture the snippet in the same manner as described above. Then, shift focus to your Word document and position the cursor where the snippet is to appear. Select the Home tab of the Ribbon, choose Paste, followed by Paste Special. In the Paste Special dialog box, select Paste Link (or Paste for an unlinked snippet) and highlight Picture (Windows Metafile) in the Format As box. Click OK to complete the operation. This result can be replicated without using the Camera by simply copying a range and then pasting the range into Word using Paste Special, Picture (Windows Metafile) with or without a link.

[bookmark: Custom_Views][bookmark: _bookmark249]Custom Views
One of the little-known but powerful features of Excel is the ability to create views of a worksheet for use on demand. The feature, referred to as Custom Views, can be used to navigate or arrange a worksheet for a specific purpose or for capturing print settings so that a single worksheet can have multiple print settings, such as page orientation, margins, or headers and footers. Most accounting professionals have set up a worksheet to print an area, only to have to reset the same worksheet to print another area, perhaps several times over. Further, they may do this many times each month in multiple workbooks to create the reports that are needed. Custom Views can automate the process of creating multiple print areas and modifying the print settings without writing any macros. This has the potential to improve staff productivity dramatically.

Before we cover Custom Views for printing, let us examine Custom Views as a means of navigating and rearranging a worksheet.

To create a Custom View, do the following.

1. Rearrange the worksheet on the screen just as you want to use it, including re- positioning the cursor to the likely point of use.

2. From the View tab of the Ribbon, select Custom Views. In the Custom Views dialog box, click Add. In the Name box of the Add View dialog, type in a name for your view and click OK.

To use this view, simply select Custom Views from the View tab of the Ribbon. Then, highlight the view in the dialog box and click Show as shown in Figure 15. Your worksheet instantly rearranges to show the view as it was created.
[image: ]

[bookmark: _bookmark250]Figure 15 - Selecting a Custom View

Adding the Custom Views command to your QAT allows you to change views quickly from the desktop without using the dialog box.

Views can include settings for hidden rows and columns, frozen panes, window splits, data filters, and printing. You cannot edit a view directly. However, to work around this limitation, display the view that needs to be changed. Make the changes to the view as required and choose to add a new Custom View as described previously, making sure to save the view with the same name. Confirm the change by clicking Yes to the overwrite warning.

[bookmark: Using_Custom_Views_to_Automate_Print_Set][bookmark: _bookmark251]

Using Custom Views to Automate Print Settings
As mentioned previously, Custom Views can contain print settings such as defined Print Areas. They can also contain all other print settings defined in the Page Setup dialog box. For example, a  view can contain settings for margins, shrink to fit, page orientation, headers and footers, rows or columns to be repeated, whether gridlines are to be printed, and even the printer from which the view is to be printed. Any print setting defined in the Page Setup dialog box can be captured in a view. Just make sure to set all relevant print settings before creating the Custom View.
.
	
	Each workbook has its own set of Custom Views, so they must be created in each workbook or be included in user-defined templates. The use of templates was examined in Chapter Three.

Since Custom Views are defined within workbooks, a view to another workbook cannot be accomplished directly. An effective workaround is to bring the desired data into the workbook where it is to be viewed or printed, using formulas or Camera objects linked to the source workbook.
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