
 

 
 

Excel Macros 
Demystified 

 
 
 
 
 

 
 
 
Utilizing Excel macros can help you automate many repetitive activities. Unfortunately, many Excel 
users labor under the assumption that creating and working with macros is necessarily a difficult and 
tedious task that involves learning a programming language. In fact, most Excel users can take 
develop and use their own macros by simply adding a few keystrokes to processes in which they are 
already engaging. In this chapter, you will learn how to take advantage of macros. 
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Creating your First Macro in Less than Two 
Minutes 

Case Study in Recording Macros 
Sean, a CPA working for a mid-sized public accounting firm, finds himself performing the same 
task each and every month for several of his small business clients – exporting financial 
statements from the clients’ accounting software applications to Excel, reformatting the 
statements to meet the firm’s standards, and printing the statements. While the task is not 
difficult, it is monotonous in that it involves making the same formatting modifications every 
month. Sean feels that most of these modifications are clerical in nature but is reluctant to hand 
the job over to his support staff. Adding insult to injury, he notices that the firm’s partners – the 
ones requiring him to reformat the statements – evidently do not place great value on this effort 
as they do not bill his clients for the full value of the time he spends on reformatting and printing 
the financial statements. Sean believes there must be a better, more efficient approach to 
performing these repetitive tasks. 
Sean has heard of macros in Excel and other applications. Though Sean does not yet have a 
deep knowledge of macros, he understands that they are ideal tools to execute repetitive 
keystrokes and decides to attempt to write an Excel macro to solve his financial statement 
formatting problem. However, he realizes he has no knowledge of the programming language 
Excel uses for macros – Visual Basic for Applications (VBA) – and, further, he does not have 
the time necessary to learn this programming language. In lamenting his plight over lunch with 
Jamie, another CPA working at the firm, he learns that he may be able to write the macro without 
any knowledge of VBA whatsoever. Jamie tells him about a tool in Excel known as the Macro 
Recorder and about how she used the macro recorder just a few weeks ago to write some very 
useful and practical Excel macros she uses on a daily basis. Jamie tells Sean that the Macro 
Recorder is very easy to use; all users have to do is turn it on, execute Excel keystrokes as they 
normally would, and then turn the Macro Recorder off. Excel will convert all of the keystrokes 
into VBA and store the code as a macro. Once stored, Sean can recall and play back the macro 
on demand. Newly encouraged, Sean decides to go back to the office and attempt to write his 
first macro using the tool Jamie has discussed with him. 

 
To begin his quest, Sean starts the accounting application containing one of his client’s data – 
in this case, QuickBooks. He opens one of the financial statements that he has to reformat each 
month, the Profit & Loss YTD Comparison shown in Figure 1. 



 

 

Figure 1 – Financial Statement for Export to Excel 

With the financial statement open, Sean clicks the Export… button to export the financial 
statement to Excel. Immediately upon doing so, and before Sean begins any of his modification 
efforts, the financial statement appears in Excel as shown in Figure 2. Among the modifications 
Sean would like to automate with his macro are: 

 
• Changing the title of the report to “Statement of Income,” 

 
• Deleting the current entries in cells J1 through J3, 

 
• Formatting the numbers in the financial statement in the Accounting Format without 

currency symbols, with the exception of the first and last rows which will have currency 
symbols. 

 
• Moving the current “% of Income” column so that it is between the current month 

column and the year-to-date column, 
 

• Adding a “% of Income” column to calculate percentages based on year-to-date 
numbers, 

 
• Changing the reference for “Income” to “Revenue” and for “Total Income” to “Total 

Revenue,” 
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• Changing the reference for “Total COGS” to “Total Cost of Goods Sold,” and 
 

• Centering the report’s three-line header across the width of the report. 
 
 

 
 

Figure 2 - Exported Financial Statement in Excel 
 

With the financial statement workbook open, Sean clicks the drop-down arrow under Macros 
on the View tab of the Ribbon and chooses Record Macro… to start the Macro Recorder as 
shown in Figure 3. If Sean had previously activated the Developer tab of the Ribbon, he could 



 

start the Macro Recorder by clicking Record Macro on the Developer tab of the Ribbon. In 
either case, the Record Macro dialog box appears as shown in Figure 4. 
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Figure 3 - Starting the Macro Recorder from the View Tab of the Ribbon 
 

 
Figure 4 - The Record Macro Dialog Box 



 

In the Record Macro dialog box, Sean is asked to enter four elements of information: 
1. The name of the macro, 
2. A shortcut key (optional), 
3. Where the macro will be stored, and 
4. A description of the macro (optional). 

 
Because Sean doesn’t yet understand all of the ramifications of these choices, he makes his best 
guess and enters the data in the Record Macro dialog box shown in Figure 5. 

 

Figure 5 - Sample Entries in the Record Macro Dialog Box 
 
Upon clicking OK, Sean notices a button appear in the lower, left-hand corner of the Excel 
window; Sean remembers that Jamie told him to click this button – the Stop Recording button 
– when he was through entering the keystrokes he wished the Macro Recorder to record for him 
and translate into VBA. Figure 6 displays the Stop Recording button. 

 

Figure 6 - The Stop Recording Button for the Macro Recorder 
 
With the Macro Recorder turned on, Sean executes each of the keystrokes required to complete 
his desired reformatting objectives listed beginning on page 15. When he has completed the 
keystrokes, he clicks the Stop Recording button to turn the Macro Recorder off. His reformatted 
financial statement appears as shown in Figure 7. 
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Figure 7 - Manually Reformatted Financial Statement in Excel 
 
Sean saves the workbook but, instead of saving it as a traditional Excel workbook with a .xlsx 
extension, he is prompted by Excel to save it as a macro-enabled workbook; a macro-enabled 
workbook has a .xlsm file extension. To save the workbook in this format, 



 

Sean clicks Save As and selects Excel Macro-Enabled Workbook in the Save as type drop- 
down box as shown in Figure 81. 

 

 
Figure 8 - Saving a Workbook as a Macro-Enabled Workbook 

 
Sean is anxious to test his newly recorded macro to see if it will, indeed, reformat his client’s 
financial statement and save him the time of performing this task manually each and every 
month. To do so, Sean first exports the financial statement from his client’s accounting software 
data file to Excel. Then, he clicks Macros on either the View tab or the Developer tab of the 
Ribbon to open the Macro dialog box shown in Figure 9. On the Macro dialog box, Sean selects 
his newly recorded Format macro and clicks Run. Upon doing so, his screen flickers and 
flashes for a couple of seconds before returning a perfectly formatted financial statement. Sean 
realizes that Jamie was right about the ease with which certain macros can be recorded and 
begins to think of other macros he can record to automate repetitive tasks. It was a very good 
day for Sean! 

 
 
 
 
 
 
 
 
 
 

 
 

1 Alternatively, Sean may have chosen to save the macro in an Excel Macro-Enabled Template. Such a file has 
a.xltm file extension. A potential advantage to working with a template file instead of a workbook file is that Sean 
faces far less risk that he will accidentally overwrite the contents of the template file. 
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Figure 9–Running a Macro to Reformat Financial Statements 



 

Macro Recorder Postscript 
For those previously uninitiated in writing and using macros, Sean’s use of the Macro Recorder 
seemingly presents a single solution to writing macros. That is, simply turn on the Macro 
Recorder, enter the requisite keystrokes for the task at hand, then turn off the Macro Recorder 
and, presto, instant macro. The Macro Recorder did all of the heavy lifting for Sean and 
converted his keystrokes into the code you see below. 

 
Sub Format() 

' Format Macro 

' Macro to automatically format the financial statements for Carl's Computer Shop 

Range("A2").Select 

ActiveCell.FormulaR1C1 = "Statement of Income" 

Range("J1:J3").Select 

Selection.ClearContents 

Range("J5:J28").Select 

Selection.Cut Destination:=Range("G5:G28") 

Range("G5:G28").Select 

Columns("G:G").EntireColumn.AutoFit 

ActiveWindow.ScrollRow = 13 

ActiveWindow.ScrollRow = 12 

ActiveWindow.ScrollRow = 11 

ActiveWindow.ScrollRow = 10 

ActiveWindow.ScrollRow = 9 

ActiveWindow.ScrollRow = 8 

ActiveWindow.ScrollRow = 7 

ActiveWindow.ScrollRow = 6 

Range("G5").Select 

Selection.Copy 

Range("I5").Select 

ActiveSheet.Paste 

Columns("I:I").EntireColumn.AutoFit 

Range("I8:I28").Select 

Application.CutCopyMode = False 

Selection.NumberFormat = "General" 
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ActiveWindow.ScrollRow = 12 

ActiveWindow.ScrollRow = 11 

ActiveWindow.ScrollRow = 10 

ActiveWindow.ScrollRow = 9 

ActiveWindow.ScrollRow = 8 

ActiveWindow.ScrollRow = 7 

ActiveWindow.ScrollRow = 6 

Range("I8").Select 

ActiveCell.FormulaR1C1 = "=+RC[-1]/R8C[-1]" 

Range("I8").Select 

Selection.Copy 

Range("I8,I9,I11,I12,I13,I15,I16,I17,I18,I19,I20,I21,I22").Select 

Range("I22").Activate 

ActiveWindow.SmallScroll Down:=11 

Range( _ 

"I8,I9,I11,I12,I13,I15,I16,I17,I18,I19,I20,I21,I22,I23,I24,I25,I26,I27,I28"). _ 

Select 

Range("I28").Activate 

ActiveSheet.Paste 

ActiveWindow.ScrollRow = 16 

ActiveWindow.ScrollRow = 15 

ActiveWindow.ScrollRow = 14 

ActiveWindow.ScrollRow = 13 

ActiveWindow.ScrollRow = 12 

ActiveWindow.ScrollRow = 11 

ActiveWindow.ScrollRow = 10 

ActiveWindow.ScrollRow = 9 

ActiveWindow.ScrollRow = 8 

ActiveWindow.ScrollRow = 7 

ActiveWindow.ScrollRow = 6 

Range("G8:G28").Select 

Application.CutCopyMode = False 

Selection.Copy 



 

ActiveWindow.ScrollRow = 12 

ActiveWindow.ScrollRow = 11 

ActiveWindow.ScrollRow = 10 

ActiveWindow.ScrollRow = 9 

ActiveWindow.ScrollRow = 8 

ActiveWindow.ScrollRow = 7 

ActiveWindow.ScrollRow = 6 

Range("I8").Select 

Selection.PasteSpecial Paste:=xlPasteFormats, Operation:=xlNone, _ 

SkipBlanks:=False, Transpose:=False 

Application.CutCopyMode = False 

Range("G8:G28").Select 

Selection.NumberFormat = "#,##0.0##%;-#,##0.0##%" 

Selection.NumberFormat = "#,##0.0#%;-#,##0.0#%" 

ActiveWindow.ScrollRow = 12 

ActiveWindow.ScrollRow = 11 

ActiveWindow.ScrollRow = 10 

ActiveWindow.ScrollRow = 9 

ActiveWindow.ScrollRow = 8 

ActiveWindow.ScrollRow = 7 

ActiveWindow.ScrollRow = 6 

Selection.NumberFormat = "0.00%" 

Range("I8:I28").Select 

Selection.Style = "Percent" 

Selection.Style = "Percent" 

Selection.NumberFormat = "0.0%" 

Selection.NumberFormat = "0.00%" 

ActiveWindow.ScrollRow = 12 

ActiveWindow.ScrollRow = 11 

ActiveWindow.ScrollRow = 10 

ActiveWindow.ScrollRow = 9 

ActiveWindow.ScrollRow = 8 

ActiveWindow.ScrollRow = 7 
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ActiveWindow.ScrollRow = 6 

Range("D7").Select 

ActiveCell.FormulaR1C1 = "Revenue" 

Range("D9").Select 

ActiveCell.FormulaR1C1 = "Total Revenue" 

Range("D12").Select 

ActiveCell.FormulaR1C1 = "Total Cost of Goods Sold" 

Range("F8,H8").Select 

Range("H8").Activate 

ActiveWindow.ScrollRow = 7 

ActiveWindow.ScrollRow = 8 

ActiveWindow.ScrollRow = 9 

ActiveWindow.ScrollRow = 10 

ActiveWindow.ScrollRow = 11 

ActiveWindow.ScrollRow = 12 

ActiveWindow.ScrollRow = 13 

Range("F8,H8,F28,H28").Select 

Range("H28").Activate 

Selection.Style = "Currency" 

Range("H9:H27").Select 

Range("H27").Activate 

Selection.Style = "Comma" 

Range("F9:F27").Select 

Selection.Style = "Comma" 

Range("A1:I3").Select 

With Selection 

.HorizontalAlignment = xlCenterAcrossSelection 

.VerticalAlignment = xlBottom 

.WrapText = False 

.Orientation = 0 

.AddIndent = False 

.IndentLevel = 0 

.ShrinkToFit = False 



 

.ReadingOrder = xlContext 

.MergeCells = False 

End With 

Range("A1").Select 

End Sub 

However, the Macro Recorder is not a single or perfect solution to all macro tasks as there are 
several limitations surrounding the functionality of the Macro Recorder. For instance, the Macro 
Recorder cannot be used to write a macro which pauses to allow a user to input data into a cell. 
Likewise, the Macro Recorder cannot be used to write a macro in which DO/WHILE or 
IF/THEN/ELSE logic is required. To overcome these limitations, writing and editing VBA 
code is necessary. Nonetheless, the Macro Recorder is a great first step into the world of macros. 
In fact, many seasoned VBA programmers use the Macro Recorder to create the “foundation” 
code necessary for their macros and then edit that code to create more complex macros. These 
types of techniques will be discussed beginning in Chapter Four. 

 

Summary 
As shown in this chapter, macros can be extremely valuable tools for accountants and other 
business professionals to automate otherwise time-consuming, repetitive tasks. Though macros 
are written in a programming language known as VBA, the Macro Recorder tool in Excel can 
capture sequences of keystrokes and convert the keystrokes into a VBA-based macro. The 
Macro Recorder is accessible from either the View tab of the Ribbon or the Developer tab of 
the Ribbon. To use it, turn it on, execute the keystrokes otherwise required to perform the task 
at hand, and turn it off. For security reasons discussed in detail later in this course, users must 
save Excel workbooks containing macros as macro-enabled workbooks. Once a macro is 
recorded, select Macros from either the View tab or the Developer tab of the Ribbon to play it 
back, click the desired macro, and select Run. 

 
As will be discussed in subsequent chapters, while the Macro Recorder is a great tool, it does 
have some rather significant limitations; as such, those users requiring more advanced macro 
functionality will likely require at least a working knowledge of programming with VBA. 
Nonetheless, the Macro Recorder should not be overlooked as a serious tool when attempting 
to automate repetitive tasks. 
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Understanding Macro Fundamentals 

What is a Macro? 
According to Microsoft, “a macro is a series of commands and functions that are stored in a 
Microsoft Visual Basic module and can be run whenever you need to perform the task.” 
Wikipedia expands on that definition by offering that “a macro is a rule or pattern that specifies 
how a certain input sequence (often a series of characters) should be mapped to an output 
sequence (also often a series of characters) according to a defined procedure.” At K2 
Enterprises, we have defined a macro in the past as “a way to automate some routine task that 
can be clearly defined.” The three cited definitions in the preceding paragraph have a common 
theme – automating a task according to a procedure prescribed by a computer program. Thus, 
we will settle on the following for our working definition of Excel macros. 

 
A macro is a series of commands and instructions stored in a computer 
program that allows users to automate tasks according to the rules and 
parameters contained in that computer program. 

Macros are certainly not new; in fact, they have been around in spreadsheets since the very early 
days. For instance, Lotus 1-2-3 users created macros to automate print jobs and other repetitive 
tasks. In fact, the Lotus 1-2-3 print macro shown in Figure 10 will likely ring familiar with 
many. In sequence, the characters in the macro instructed Lotus 1-2-3 to Print, to the Printer, 
after Aligning the paper, Go, Page eject, and Quit. 

 
 

 

Figure 10 - Vintage Lotus 1-2-3 Macro Used for Printing 
 

Although there were special macro programming languages in Lotus 1-2-3, most early Lotus 1- 
2-3 macros were simply a series of keystrokes typed into a cell as a label. As evidenced above, 
the scripting language used by Lotus 1-2-3 was somewhat simplistic, though quite powerful. 

 
Early versions of Excel also had their own unique macro programming language. However, 
beginning with Excel version 5, Microsoft did away with having a separate macro programming 
language. For former Lotus 1-2-3 users who created macros to automate print jobs and other 
repetitive tasks, having a set of “macro commands” that only worked in macros was the norm. 
However, Microsoft decided that having a unique macro language was not a good, long term 
strategy. It required a separate development team and a separate support team and was 
permanently limited in its power and flexibility because of its limited application. 

 
Instead of continuing with a unique macro programming language, Microsoft chose to use a 
modified version of the very popular and very powerful visual basic programming language 
alled Visual Basic for Applications (VBA) as the 
macro language for Microsoft Office applications. An immediate advantage of this approach is 
the vast number of resources (i.e., books, training manuals, experienced programmers, canned 
code, etc.) that overnight became available to Office users. Note that VBA macros are not 



 

limited to Excel but are available in  many  other  Office  applications,  including Word, 
Outlook, and PowerPoint; thus, once mastered, the power of macros is easily extended into other 
applications used on a daily basis by accountants and other business professionals. 

 

Accessing Macro Functionality 
Macro functionality may be accessed in several places in Excel. For instance, basic macro 
functionality such as viewing macros, recording macros, and turning relative referencing on and 
off is accessible from the View tab of the Ribbon as shown in Figure 11. 

 

 
 

Figure 11 - Accessing Macro Functionality from the View Tab of the Ribbon 
 
However, to gain access to detailed and deep macro functionality, users must first activate the 
Developer tab of the Ribbon. By default, Microsoft does not activate the Developer tab of the 
Ribbon. The rationale for this decision is that the overwhelming majority of Excel users do not 
want access to this functionality and, consequently, there is no need to add clutter and 
complexity to the Ribbon by making the Developer tab visible. Fortunately, for those who do 
want and need the functionality found on the Developer tab, it is easy to activate. To customize 
the Ribbon in Excel 2010 and Excel 2013, right-click on the Ribbon and choose Customize 
Ribbon to open the window shown in Figure 12. Alternatively, you can choose File, Options, 
and Customize Ribbon to open the window. On the right-hand side of the window, check the 
box next to Developer and click OK to enable this functionality. 
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Figure 12 - Activating the Developer Tab of the Ribbon in Excel 2013 
 
Users of Excel 2007 enable the Developer tab by clicking the Office Button and Excel Options. 
Then, on the Popular tab, check the box next to Show Developer tab in the Ribbon and OK 
as shown in Figure 13. 



 

 

 
 

Figure 13 - Activating the Developer Tab of the Ribbon in Excel 2007 
 
Once a user activates the Developer tab, virtually all of Excel’s macro functionality is available 
from that tab of the Ribbon as shown in Figure 14. 

 

Figure 14 - Developer Tab of the Ribbon 
 
On the Developer tab, three groups are of particular significance when working with macros. 

 
1. Code – The Code group contains icons used to access five functions related to recording 

and playing back macros. 
a. Visual Basic icon, providing access to the Visual Basic Editor 
b. Macros icon, providing access to the Macro dialog box 
c. Record Macro icon, which turns on the Macro Recorder 
d. Use Relative References icon, which turns relative references on and off 
e. Macro Security icon, providing access to the Trust Center. 
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2. Add-Ins – The Add-Ins group contains two icons used to manage Excel add-ins. 

a. Add-Ins icon, providing access to activating and de-activating Excel add-ins 
b. COM Add-Ins icon, used to manage Common Object Model add-ins 

 
3. Controls – The Controls group contains icons used to access five functions related to 

work with programming controls on a worksheet. 
a. Insert icon, providing access to an assortment of programming controls 
b. Design Mode icon, providing access to design tools related to an ActiveX 

control 
c. Properties icon, providing access to a control’s properties 
d. View Code icon, providing access to VBA code inside the Visual Basic Editor 
e. Run Dialog icon, providing access to a custom dialog box or user form designed 

in VBA. 
 

Naming Macros 
In the first chapter, Sean entered a simple name – Format – for his macro. When assigning a 
name to a macro, there are a few simple rules that users must follow. 

 
• The first character of the name must be a letter. 
• Numbers and special characters such as underscores are allowed in a macro name, but 

they cannot begin the macro name. 
• Spaces are not allowed in macro names; a common workaround for this limitation is to 

use an underscore character in lieu of spaces. 
• A macro cannot have the same name as a cell reference or another named object in the 

workbook. 
 
If a user attempts to assign a name to a macro that is the same as a cell reference or any other 
named object in the workbook or that violates any of the other naming rules, Excel will display 
the error message shown in Figure 15. 

 

Figure 15 - Macro Naming Error in Excel 
 
Based on the naming rules outlined above, any of the following would have been among the 
valid names for Sean’s macro. 



 

• FormatReport 
• Format_Report 
• Format1 

Likewise, each of the following would have been disallowed for Sean’s macro. 
 

• 1Macro 
• Format Report 
• A1 

Shortcut Keys 
When creating a macro, users can assign a shortcut key to it so that all users have quick and 
easy access to playing back the macro. By doing so, users will be able to execute the macro with 
a combination of a CTRL+keystroke or a CTRL+SHIFT+keystroke combination instead of 
accessing the Macro dialog box for playback. 

 
In the example in the first chapter, Sean elected not to assign a keyboard shortcut. He could 
have, for example, entered an “R” in the shortcut key field. Had he done so, then the keyboard 
shortcut of CTRL + R could have been used to execute the macro. 

 
With respect to shortcut keys, it must be noted that users should exercise extreme caution when 
assigning shortcut keys. For example, had Sean used CTRL + F as his keyboard shortcut, he 
would have overridden the preexisting Excel keyboard shortcut to the Find & Replace function. 
Unfortunately, Excel provides no advance warning that the newly assigned keyboard shortcut 
is about to replace the existing keyboard shortcut. As such, a best practice is to test the desired 
keyboard shortcut prior to assigning it to a macro. If the desired keyboard shortcut is already in 
use by Excel, consider adding the SHIFT key to the macro shortcut. 

 

Storing and Deleting Macros 
When creating a macro, the developer may choose to store the macro in one of three locations: 

 
1. The current workbook, 
2. The Personal Macro Workbook, or 
3. Another workbook. 

 
The proper decision here is critical to being able to access and run the macro when it is needed. 

 
If a macro is stored in the current workbook, it will only be available when the current workbook 
is open. This is often the correct choice when the macro is specific to a particular report or 
project and only needs to be available when a user is working on that specific report or project. 

 
Likewise, saving a macro in another workbook makes the macro available only when the other 
workbook is open. Thus, users must know to open the other workbook in which the macro is 
saved before attempting to run the macro. 
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Saving the macro in the Personal Macro Workbook makes the macro available whenever Excel 
is open. Each user has a separate Personal Macro Workbook entitled personal.xlsb. By default, 
the Personal Macro Workbook is hidden; most users will never need to and likely should not 
unhide it. Saving a macro in the Personal Macro Workbook is typically the proper choice when 
the macro is one that is often used for formatting or other general purpose utility functions. 

 
Deleting a macro that was stored in other than Personal Macro Workbook is a straightforward 
process. From the Macro dialog box, simply choose the macro to delete and click the Delete 
button as shown in Figure 16. 

 

Figure 16 - Deleting a Macro 
 
In addition to deleting macros by selecting them in the Macro dialog box and clicking Delete, 
users can also delete them from within the Visual Basic Editor. Working with the Visual Basic 
Editor is discussed beginning in Chapter 4. 

 
 
Deleting Macros from the Personal Macro Workbook 
Notwithstanding the previous recommendation to keep the Personal Macro Workbook hidden, 
there is one particular instance when many users may need to unhide it and act upon it. If a 
macro is stored in the Personal Macro Workbook, and a user wishes to delete that macro, it 
would be natural to assume that selecting the macro in the Macro dialog box and choosing 
Delete would delete the macro. However, doing so generates the error message shown in Figure 
17. 



 

 

 
 

Figure 17 - Attempting to Delete a Macro from the Personal Macro Workbook 
 
The solution to this problem is to unhide the Personal Macro Workbook, make it the active 
workbook, and then delete the macro. To do this, begin on the View tab of the Ribbon by 
clicking Unhide. In the Unhide dialog box shown in Figure 18, select the Personal Macro 
Workbook and click OK to unhide the workbook. 

 

Figure 18 - Unhiding the Personal Macro Workbook 
 

With the Personal Macro Workbook unhidden and active, return to the Macro dialog box, select 
the macro to delete, and click OK. This time Excel will delete the macro. Once the macro is 
deleted, hide the Personal Macro Workbook by selecting Hide from the View tab of the Ribbon. 
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Of course, as is often the case in Excel, there is another practical solution to this problem, and 
that is to delete the macro from within the Visual Basic Editor, as mentioned previously. 

 

Absolute vs. Relative Cell References in Macros 
One of the most challenging issues facing those new to macros is understanding how a given 
macro operates based on whether it is built using absolute or relative cell references. By default, 
Excel records macros using absolute referencing; this means that as the macro is being 
recorded, Excel records and acts upon the exact location of the cellpointer. In other words, if the 
cellpointer is in cell A1 when recording the macro begins, and the person recording the macro 
then clicks in cell C3 – two rows down and two rows over from cell A1 – Excel will perform 
whatever action is being recorded on cell C3. On the other hand, if relative referencing is 
enabled, Excel will move the cellpointer down two rows and over two columns, regardless of 
the starting location. Thus, following the previous example, if the starting location is cell D5, 
Excel will reposition the cellpointer while the macro is being played back to cell F7. 

 
Again, by default, all macros are recorded with absolute referencing, and this is the desired 
functionality in many cases. However, there are also many cases where relative referencing is 
necessary. To enable relative referencing, click the Use Relative References from either the 
View tab of the Ribbon or the Developer tab of the Ribbon as shown in Figure 19. 

 

 
Figure 19 - Selecting Relative Referencing 

 
Without becoming bogged down in the details of the VBA code, Figure 20 displays the 
differences between the effect of using relative references and absolute references. In the relative 
reference example at the top half of the figure, the phrase “This is an example of relative 
referencing.” will be entered four rows down and three columns to the right of the active cell. 
In the example at the bottom half of the window, the phrase “This is an example of absolute 
referencing.” will always be entered in cell C5. 



 

 

 
 

Figure 20 - Difference between VBA Code when Using Relative and Absolute Referencing 
 

Macro Security 
Why Managing Macro Security is Necessary 
Before considering the different options for managing macro security, it is first necessary to 
understand why this topic is so important. Put simply, left unsecured, macros carry the risk of 
introducing malicious code into a user’s computer. Keeping in mind that macros are nothing 
more than computer programs, it is possible for someone to either purposefully or accidentally 
include malicious and damaging code in a macro. If that macro is then passed along to other 
users who execute it on their computers, then the malicious code spreads and potentially harms 
the other computers or compromises data on them. With this bit of background, it becomes 
obvious that managing the security risk associated with macros is necessary in order to be able 
to utilize macros to their fullest extent. Otherwise, accountants and other business professionals 
run the unacceptable risk of compromising sensitive personal, client/customer, or corporate 
data. 

 

Default Macro Security Settings 
Macro security begins with the type of Excel files into which users can save macros. A 
traditional Excel workbook with a.xlsx file extension cannot contain macros. In fact, the only 
three types of workbooks that can contain macros are macro-enabled workbooks with .xlsm file 
extensions, macro-enabled templates with .xltm file extensions, and binary workbooks with 
.xlsb extensions; the Personal Macro Workbook described previously is an example of a binary 
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workbook2. The purpose of these restrictions is to reduce the likelihood that a user unknowingly 
or unwittingly opens an Excel workbook that contains potentially malicious macro code. 

 
A second layer of macro security is provided by using trusted locations. By default, Excel 
disables macros in all workbooks that are not stored in a trusted location. According to 
Microsoft, 

 
A trusted location is typically a folder on your hard disk or a network share. 
Any file that you put in a trusted location can be opened without being checked 
by the Trust Center security feature. 

 
The Trust Center mentioned in the definition of trusted locations provides “one-stop shopping” 
for most of Excel’s critical security functions. To access the Trust Center in Excel 2010 and 
Excel 2013, select File, Options, Trust Center, and Trust Center Settings. In Excel 2007, 
click the Office Button, Excel Options, Trust Center, and Trust Center Settings to access 
the Trust Center. 

 
If a workbook containing a macro which is not stored in a trusted location is opened, Excel, in 
default, supplies the warning message shown in Figure 21. 

 

Figure 21 - Macro Security Warning Message 
 
By clicking on the Enable Content button, a user activates the macros in the workbook. 
Otherwise, the macros in that workbook remain disabled. 

 

Adding a Trusted Location 
Upon installing Excel, several trusted locations are created automatically. As shown in Figure 
22, the most prominent of these are the XLSTART folders and template folders. 

 
 
 
 
 
 
 
 

2 In versions of Excel prior to 2007, such restrictions were not in place. For example, macros could be stored in 
“normal” workbooks with .xls file extensions in Excel 2003. 



 

 

 
 

Figure 22 - Trusted Locations in Excel 2013 
 

To add a new trusted location, click the Add new location…button shown in Figure 22 to open 
the Microsoft Office Trusted Location dialog box pictured in Figure 23. Enter the path for the 
new trusted location, indicate whether the trusted location also includes subfolders of that path, 
add an optional description, and click OK to complete the process. Upon doing so, Excel will 
explicitly trust all workbooks stored in the newly created trusted location, including those 
workbooks containing macros. 

 

Figure 23 - Microsoft Office Trusted Location Dialog Box 
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Managing Macro Security in Workbooks not Stored in a 
Trusted Location 
If a workbook is not stored in a trusted location, users can still manage the security of macros 
within that workbook by changing the Macro Settings options in the Trust Center. 

 

Figure 24 - Macro Settings in the Trust Center 
 
As shown in Figure 24, the Trust Center contains four levels of Macro Settings: 

 
1. Disable all macros without notification, 
2. Disable all macros with notification, 
3. Disable all macros except digitally signed macros, and 
4. Enable all macros (not recommended; potentially dangerous code can run). 

 
The default for Macro Settings in the Trust Center is Disable all macros with notification. 
That setting requires a user to consciously enable macros in a workbook that is not stored in a 
trusted location, as shown previously in Figure 21. 

 
If a user chose the first option – Disable all macros without notification – then when that user 
opened a workbook not stored in a trusted location, all macros would be disabled, and there 
would be no notification to the user similar to that displayed in Figure 21. 

 
Choosing Disable all macros except digitally signed macros causes Excel to disable all 
macros from workbooks in non-trusted locations, unless the workbook was previously digitally 
signed by the publisher, and the publisher is recognized as a trusted publisher. For all practical 
purposes, this level of security is the same as the default setting of disable all macros with 
notification, in that if the macro is signed, but the publisher is not recognized as a trusted 
publisher, then the user is notified to that effect, and the user can choose to add the publisher to 
the list of trusted publishers. 



 

The fourth and final option is to Enable all macros (not recommended; potentially 
dangerous code can run). As the name implies, this is a dangerous choice, since macros are 
able to run without being subjected to the security regime. 

 

Summary 
In this chapter, we reviewed several of the fundamentals associated with macros. The principles 
discussed apply to all macros – whether recorded by the Macro Recorder or entered directly into 
the Visual Basic Editor. Because of completing this chapter, participants know that some macro 
functionality is accessible from the View tab of the Ribbon; however, activating the Developer 
tab of the Ribbon is necessary to get to more advanced functionality. Participants also gained 
knowledge about the rules associated with naming macros and how to assign keyboard shortcut 
keys to macros, including the risks associated with keyboard shortcuts. Additionally, the 
importance of choosing the proper storage location – including the Personal Macro Workbook 
– for macros was reviewed, along with how to delete macros. Finally, the all-important topic of 
managing macro security – including trusted locations and trusted publishers – was 
introduced in order to minimize the risk potentially associated with macros. 

 
With the knowledge gained in the first two chapters of this course, we are now ready to begin 
doing more with the Macro Recorder, including learning additional types of macros that can be 
recorded using this tool and its limitations.  
 

Working with the Macro Recorder 
 

Understanding what the Macro Recorder Does 
As its name implies and as we learned in Chapter One, once activated, the Macro Recorder 
simply records all of a user’s keystrokes until such time as the user turns off the Macro Recorder. 
To create an analogy, think of the Macro Recorder as a tape or digital voice recorder – you turn 
it on, speak into it, and turn it off, and when you want to play back your recording, you simply 
press “Play.” The Macro Recorder works much the same way – you turn it on, execute your 
keystrokes, and turn it off. When you are ready to play back those same keystrokes in the exact 
same sequence, you press “Play” to execute the macro. 
The hidden step with the Macro Recorder, however, is that not only does it act like a tape or 
digital voice recorder, it also acts like a translator, converting your keystrokes into VBA code. 
To illustrate, consider the VBA code shown in Figure 25; this macro was recorded with the 
Macro Recorder and, as shown in the figure, contains fifty-five lines of code. However, in 
addition to the keystrokes required to type in “CONFIDENTIAL Not for Disclosure Outside 
K2 Enterprises,” recording the macro required only four keystrokes/mouse clicks; the Macro 
Recorder automatically generated the remaining lines of VBA code. 
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Figure 25 - Example of a Macro to Create a Print Footer 



 

Issues Associated with Using the Macro Recorder 
If the Macro Recorder is good enough to generate fifty-five lines of code from only four 
keystrokes/mouse clicks, then why is it necessary to learn anything at all about VBA? Why 
can’t we just use the Macro Recorder as our one and only macro tool? The answer is simple – 
the Macro Recorder has some fairly significant shortcomings that prevent it from being the only 
tool in your macro toolbox. Among these are the following four items. 

 
1. The Macro Recorder sometimes generates far more code than what is actually necessary 

for the issue at hand. 
 

2. The Macro Recorder, by default, always uses absolute referencing when recording 
keystrokes. 

 
3. The Macro Recorder cannot record macros that require interactive user input, such as a 

macro that pauses and waits on a user to enter a variable. 
 

4. The Macro Recorder cannot record macros that involve branching or looping logic. 

Each of these issues is discussed below. 

Generating Superfluous Code 
As shown in Figure 25, the Macro Recorder is capable of generating a large volume of code 
from only a few keystrokes. While this does not always produce negative consequences, it does 
mean that the macro has to execute more lines of code and, as such, might run a bit slower than 
if the extraneous code did not exist. Further, it makes copying some or all of the macro and 
pasting it to another macro a bit more challenging. Thus, users frequently find it advantageous 
to pare down the code generated by the macro recorder, reducing it only to the specific lines 
required to perform the intended task. While a discussion of editing VBA code is reserved for 
Chapter Four, Figure 26 presents an edited and condensed version of the macro shown in Figure 
25. In this case, however, only the lines of code that are actually necessary to insert the print 
footer into a worksheet remain with the macro. All other lines of extraneous code were deleted. 

 

 
Figure 26 - Modified and Streamlined Macro to Create a Print Footer 
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Using Absolute versus Relative Referencing 
The Macro Recorder, by default, records with absolute referencing enabled. We learned in 
Chapter Two the differences between how macros operate when absolute referencing is enabled 
and when relative referencing is enabled. If the Macro Recorder is used to record a macro and 
if relative referencing is necessary in order for the macro to perform as intended, then turn on 
relative referencing prior to turning on the Macro Recorder. For instance, suppose you needed 
a macro to automatically insert a loan payment calculator into your worksheet beginning in the 
currently selected cell of the worksheet. Using absolute referencing, that normally would not 
constitute an issue at all. Simply click in the desired cell, turn on the macro recorder, and record 
keystrokes that resemble something similar to the outline shown in Figure 27. Of course, the 
macro creates a PMT formula in cell F10 to calculate the payment when the appropriate 
variables are entered. 

 

Figure 27 - Macro Used to Calculate Loan Payments 
 

The VBA code created by the Macro Recorder related to the example presented in Figure 27 is 
shown in Figure 28. Notice the “hard” references to cells E8, E9, E10, F7, F8, F10, and F11, 
indicating that the specified functions will always be performed on those specific cells. 



 

 

 
 

Figure 28 - VBA Code for Payment Macro Based on Absolute Referencing 
 

Now, let us record the same macro, with one small – but significant – difference. In this instance, 
we will turn on relative referencing prior to turning on the Macro Recorder. The result is the 
code pictured in Figure 29. 

 

Figure 29 - VBA Code for Payment Macro Based on Relative Referencing 
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In this case, because relative referencing was activated before the Macro Recorder was turned 
on, the macro does not contain “hard-coded” absolute references; instead, relative references 
are used throughout the macro, as evidenced by the presence of the numerous 
ActiveCell.FormulaR1C1 and ActiveCell.Offset(x,y) commands within the code. 

 

Examples of Macros Recorded with the Macro Recorder 
In addition to the macros created with the Macro Recorder previously in this course, following 
are examples of additional macros many users might find helpful to record and save in their 
Personal Macro Workbooks. 

 

Center Across Selection 
The CAS macro shown in Figure 32 is quite useful in that, when attached to the QAT or Ribbon 
as described in the following section, it applies the center across selection format data using one 
click of the mouse; otherwise, up to six mouse clicks are necessary to apply this format. 

 

 
Figure 32 - Center Across Selection Macro Created with the Macro Recorder 



 

 

Transpose 
The Transpose macro shown in Figure 33 copies a range of data and performs a Paste Special, 
Transpose on that range of data. Note that the range of data should be selected prior to executing 
the macro, though the macro will execute the “copy” command. Also, note the use of relative 
referencing in the macro. 

 

 
Figure 33 - Transpose Macro Created with the Macro Recorder 

 

NAME AND ADDRESS 
The NameAndAddress macro shown in Figure 34 enters the company’s name and address 
into the active worksheet beginning in the currently selected cell. Note the use of relative 
addressing in this macro. Should you wish the data to always be entered into a specific cell, use 
absolute addressing instead. 

 

 
Figure 34 - Name and Address Macro Created with the Macro Recorder 
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QUARTERLY INCOME STATEMENT 
The IncomeStatement macro shown in Figure 35 is used to create a five-column income 
statement – one column for each quarter and a total column. A SUM formula is included in the 
total column; this formula adds the data for each quarter for each row. 

 

 
Figure 35 - Quarterly Income Statement Macro Created with the Macro Recorder 



 

Name Format 
The NameFormat macro shown in Figure 36 is another example of a macro where relative 
referencing is required. This macro takes name, address, and city/state data entered in three 
adjoining columns and rearranges that data so that it resides in three consecutive rows. 

 

Figure 36 - Name Format Macro Created with the Macro Recorder 
 

Providing Easy Access to Macros 
Users may access all macros – whether recorded with the Macro Recorder or through the Visual 
Basic Editor – through either the Developer or View tabs of the Ribbon. In addition, you can 
create one-click shortcuts to macros on the Quick Access Toolbar (QAT) in Excel 2007, Excel 
2010, and Excel 2013. Also, in Excel 2010 and Excel 2013, you can customize the Ribbon to 
include buttons providing one-click access to macros. Both of those techniques are discussed 
below. 

 

Attaching Macros to the Quick Access Toolbar 
Excel 2007 replaced the menu structure and toolbars of prior versions of Excel with a new user 
interface known as the Fluent interface. Cornerstones of the Fluent interface include replacing 
menus with the Ribbon and toolbars with the QAT. Both the Ribbon and QAT also exist in 
Excel 2010 and Excel 2013 

 
In both Excel 2007, Excel 2010, and Excel 2013 you can – and should – customize the QAT to 
add quick and easy access to the functions with which you work most often. If there is a 
particular macro that you use often, then you should probably add it to the QAT so that you can 
access it as quickly as possible. 

 
To add a macro to the QAT, click the drop-down arrow on the QAT and select More 
Commands… as shown in Figure 37. This action opens the Quick Access Toolbar section of 
the Excel Options window. On it, select Macros from the Choose commands from: drop- 
down list as shown in Figure 38. 
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Figure 37 - Customizing the Quick Access Toolbar 



 

 

 
 

Figure 38 - Selecting to Customize the Quick Access Toolbar with Macros 
 

Next, select the macro you wish to add to the QAT and click Add>>. As shown in Figure 39, 
this causes Excel to add the selected macro to the QAT. To run the macro from the QAT, simply 
click it. 
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Figure 39 - Adding a Macro to the Quick Access Toolbar 
 

Customizing the Ribbon with Shortcuts to Macros 
In addition to customizing the QAT, Excel 2010 and Excel 2013 you can also customize the 
Ribbon directly from within Excel. While customizing the Ribbon is possible for Excel 2007 
users, it requires the use of third-party tools and is beyond the scope of this seminar. 

 
To customize the Ribbon, return to Excel Options, shown in Figure 38, and select Customize 
Ribbon. Here you may add macros to existing tabs and groups on the Ribbon, or you may create 
new tabs and groups. In this example, we will add a new tab to the Ribbon entitled Macros and 
add a macro to that tab. To add a new tab to the Ribbon, click New Tab near the bottom of the 
window as shown in Figure 40. Select the newly added tab, click Rename, and assign a more 
descriptive name, such as Macros. Repeat this process to rename the Group that Excel 
automatically added when the new tab was created. 



 

 

 
 

Figure 40 - Adding a New Tab to the Ribbon 
 
To begin adding Macros, select the Group to which the macros will be added. Then, select 
Macros from the Choose commands from: drop-down list. Finally, select the macro you wish 
to add and click Add>> as shown in Figure 41. Repeat this process for each macro you wish 
to add to the Ribbon. 

 

 
Figure 41 - Adding a Macro to the Ribbon in Excel 2013 
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Summary 
The Macro Recorder is a valuable tool for novice and advanced Excel users alike. The Macro 
Recorder serves as a “translator,” capturing and converting keystrokes into VB code that users 
save as macros. However, the Macro Recorder is far from a perfect tool. For instance, it 
generates superfluous code that we often do not need for the task at hand. By default, it records 
with absolute referencing enabled and when we require relative referencing, we must remember 
to enable it. Further, the Macro Recorder cannot record interactive macros, nor can it record 
macros with branching logic. Yet, despite these limitations, the Macro Recorder is useful in 
recording relatively simple macros, such as one that applies Center Across Selection formatting 
with one click of the mouse. Additionally, we can use the Macro Recorder to record code that 
we can harvest and use in other macros. For these reasons, all Excel users who might find the 
need to work with macros should understand the usefulness of the Macro Recorder. 
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