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Securing documents and collaborating with others are mandatory techniques for success in today’s environment. 
Fortunately, Excel provides a number of powerful options for each of these two activities, and most of these options are 
available on the Review tab of the Ribbon. On the Review tab, you will find multiple options for securing your Excel 
documents and also for sharing and working with others in real-time on the same Excel workbook. In this chapter, you 
will learn how to work more effectively with Excel’s primary security and collaboration tools. 
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Securing Excel in the Trust Center 
Excel 2007 and newer offer improved security and privacy controls over previous versions of Excel. Security 
and privacy settings for Excel workbooks have been centralized in the Trust Center. From the Trust Center, you 
can 1) enable or disable ActiveX controls, 2) enable or disable add-ins, 3) enable or disable macros, 4) enable or 
disable security alerts on the Message Bar, 5) remove or view trusted publishers, 6) block or unblock external 
content, and 7) create, remove, or change trusted file locations. Note that Excel's default settings will more than 
likely suit the security and privacy needs of most users. 
 
The Trust Center is accessible from the File tab of the Ribbon (the Office Button in Excel 2007) 
by selecting Options, Trust Center, and, finally, Trust Center Settings. Figure 1 shows the 
setting pane for macro execution. 

 

Figure 1 - Accessing the Trust Center to Modify Security and Privacy Settings 
 

Note that in default, macros are disabled with notification. Whenever a workbook that contains a macro is 
opened, users will be able to choose whether to enable the macros as shown in Figure 2. 
 

Figure 2 - Enabling Macros in a Workbook 
 
Securing Documents 
All of the capabilities for directly securing workbooks are accessible from the File tab of the Ribbon 
(the Office Button in Excel 2007). Click on the File tab and then select Info. Upon doing so, you will see 
four buttons: 1) Protect Workbook, 2) Inspect Workbook, 3) Manage Workbook, and 4) Browser View 
Options. After clicking the Protect Workbook button, you may 1) mark a workbook as final, 2) encrypt 
a workbook with a password, 3) protect the current worksheet, 4) protect the workbook for structure, 
5) restrict access using Information Rights 
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Management (IRM), and 6) add a digital signature to a workbook. Clicking the Check for Issues button enables 
users to 1) inspect the workbook’s properties, 2) check the accessibility of the workbook by those who might 
find it difficult to read, and 3) check compatibility with prior versions of Excel. Clicking the Manage Versions 
button allows you to manage prior versions of the workbook. Finally, selecting Browser View Options allows you 
to pick what others can see when they view the workbook on the Web. 
 
Excel provides several levels of protection for workbooks and workbook content. From an accountant’s 
perspective, these protection options are important in that they provide necessary tools to prevent 
unauthorized changes to financial statements, transaction journals, and other significant documents; they also 
prevent unauthorized access to these documents. The following list summarizes the levels of protection offered 
by Excel. 
 
1. Encrypted workbook with password protection – The workbook is encrypted with 128-bit AES 

encryption, and Excel requires a password to open the workbook. 
 

2. Encrypted workbook with IRM protection – The workbook is encrypted with 128- bit AES 
encryption, and you must authenticate to a Rights Management Server to open, modify, copy, 
print, or distribute the workbook. 
 

3. Unencrypted workbook with modification protection – The workbook is not encrypted, and 
anyone may open it; however, the workbook is protected from modification unless you enter the 
password to modify at the time the workbook is opened. If the password is not entered, the 
workbook is opened in read-only mode. 
 

4. Workbook structure or windows protection – The workbook is not encrypted, and anyone may 
open it; however, certain elements of the workbook are protected from modification. Workbook 
protection may be enabled with or without a password. 
 

5. User-specified worksheet element protection – The workbook is not encrypted, and anyone may 
open it; however, user-specified elements of a worksheet are protected from modification on a 
worksheet-by-worksheet basis. Worksheet protection may be enabled with or without a 
password. 
 

6. Shared workbook protection – The workbook is not encrypted, and anyone may open it; however, 
a shared workbook may not be un-shared, and the number of days maintained in the change 
history cannot be modified. Shared workbook protection may be enabled with or without a 
password. 
 
The workbook and worksheet protection options can be used together. For example, to protect 
and secure a workbook fully from unauthorized access and unwanted modification, you may 
protect specific worksheet elements, then protect the workbook, and finally encrypt the 
workbook using a password. 
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Encrypting Documents 
Excel allows you to encrypt and password-protect workbooks. Click File, Info, Protect Workbook and 
select Encrypt with Password as shown in Figure 3. For those using Excel 2007, click the Office Button, 
select Prepare, and then click Encrypt Document. 

 

Figure 3 - Encrypting a Workbook 
 

In the Encrypt Document dialog box, type a strong password and click OK. Confirm the password and click OK 
again to complete the process. In default, Excel 2007 and newer, Excel encrypts workbooks using 128-bit AES 
encryption. These passwords are not likely to be broken. Of course, you should make sure to record the 
password in a secure place. Documents saved as Office 97-2003 compatible files are encrypted using 40-bit 
encryption, which is weak by today’s standards. These 40-bit passwords can be easily broken using any of the 
available online password cracking services like those listed below. 
 

• www.decryptum.com 

• www.lostpassword.com 

• www.elcomsoft.com 

• www.accessdata.com 
 
 

  

http://www.decryptum.com/
http://www.lostpassword.com/
http://www.elcomsoft.com/
http://www.accessdata.com/
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Workbook and Worksheet Protection 
Workbooks or individual worksheets within a workbook can be protected. To protect individual sheets, first 
unlock any cells or objects that users should be able to change. To unlock cells, highlight the cells to be 
unlocked and then right-click and select Format Cells on the context- sensitive menu. On the Protection tab of 
the Format Cells dialog box, uncheck Locked. Then, select Protect Sheet on the Review tab of the Ribbon to 
open the Protect Sheet dialog box as shown in Figure 4. In the Allow all users of this worksheet to list, check 
the objects upon which users are allowed to act, then enter a password, and click OK. Confirm the password 
and then click OK again to protect the sheet. The password prevents users who do not know the password 
from un-protecting the worksheet. Repeat these steps for every worksheet that must be protected. 
 

Figure 4 - Protecting an Individual Worksheet 
 
To protect a workbook, select Protect Workbook, Protect Structure and Windows on the 
Review tab of the Ribbon to open the dialog box shown in Figure 5. 
 

 
Figure 5 - Protecting a Workbook in Excel 

 
 

Select the options desired, enter a password, and click OK. Confirm the password and click OK 
again. Note that checking Structure prevents users from taking the following actions: 
 

• Viewing worksheets that are hidden; 

• Moving, deleting, hiding, or changing the names of worksheets; 
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• Inserting new worksheets or chart sheets; 

• Moving or copying worksheets to another workbook; 

• Displaying the source data for a cell in the data area or displaying report filter pages 
on separate worksheets in PivotTable reports; 
 

• Creating a scenario summary report for scenarios; and 

• Using the analysis tools from the Analysis ToolPak that place results on a new 
worksheet. 
 
With Excel 2010 and prior, you can also check Windows to prevent users from taking the 
following actions: 
 

• Changing the size and position of the windows for the workbook when the workbook 
is opened and 
 

• Moving, resizing, or closing a window. 
 

 Note that using passwords to restrict the modification of worksheets or 
workbooks does not encrypt the workbooks. Passwords that restrict 
modifications (formatting and editing, etc.) are weak passwords that 
can be easily broken by online password cracking services. 

 

If your business or enterprise uses Windows Server 2003 or newer for 
domain control, Windows user authentication can be used as an 
alternative to using passwords. This method encrypts the document, 
but only specified authenticated users will have access. Note that this 
method of securing a document cannot be used across multiple 
businesses or enterprises because not all users will be authenticated 
on the same network. 

 

As mentioned previously and as shown in Figure 5, users of Excel 2010 or newer can also access both 
worksheet and workbook protection settings by selecting File, Info, and Protect Workbook. 

 
 

Preventing Changes to Documents 
One of the more significant of Excel's newer features is that of marking a document Final. When a document – 
such as a set of financial statements – has been marked final, Excel disallows future changes to that document 
as long as the document retains its final status. While Mark as Final is a welcome feature, users should rely on it 
only to prevent accidental or inadvertent changes to a document. Mark as Final should not be considered a true 
security feature, because users can easily remove the final status from a document and, once that has been 
removed, edit the document. 
 
To add the final status to a document, click File, Info, Protect Workbook, and Mark as Final as shown 
in Figure 9; Excel 2007 users should click the Office Button and select Prepare, Mark as Final. This 
makes the document read-only and prevents changes to the document as long as it retains this status. 
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To remove the final status from a document, repeat the steps outlined, and the document will return 
to an editable status. 
 

 

 
 

Figure 9 - Marking a Document as Final 
 

Sending Workbooks Via Email 
The most common means of collaboration among users is by email. You can send workbooks as attachments 
to email messages to other users for their input, revision, or review; Excel makes this easier by automating the 
process. To send a workbook to other users by email, select File, Share, Email, and Send as Attachment as 
shown in Figure 10. If you are using Excel 2007, you perform this function by clicking Send, Email from the 
Office Button. Note also that workbooks can also be sent as PDF or XPS attachments or via an Internet-based 
fax service. 
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Figure 10 - Sending a Workbook as an Attachment 
 
In addition, depending upon what version of Excel you are running and whether you store your 
documents in a cloud-based repository such as OneDrive for Business, you may also be able to send 
a link to your document by choosing the Send a Link option in Figure 15. Sending a link can facilitate 
real-time collaboration as all users of the link will access and edit the same workbook in real-time. 
 
Excel Workbooks and Excel Online 

Another means of sharing Excel workbooks is via an Office 2010 and newer feature entitled Excel 
Online. Excel Online allows users to share Excel documents over the Internet. Additionally, similar 
apps exist for Word, PowerPoint, and OneNote. Remote users can access and edit the documents, 
and these edits can be performed collaboratively and in real time. Thus, the author of an Excel 
workbook which is used to calculate the tax accrual for a large corporation could share that workbook 
through Excel Online so that the accountant in public practice could review and edit the workbook in 
real time with the author. 
 
To access documents using Excel Online, you must store your document in a cloud-based location 
such as OneDrive, OneDrive for Business, or SharePoint Online. After you do so, you and other users 
can simply open the document from that cloud-based storage location and begin collaborating in real 
time. As shown in Figure 11, Excel Online does not offer all the features the desktop version of Excel 
offers. Nevertheless, Excel Online provides – for many, if not all, users – a superior option for 
collaborating compared to emailing workbooks to multiple 

recipients. Further, if you need access to a feature not provided in Excel Online, you can open the 
cloud-based workbook with the desktop version of Excel, perform any necessary edits, and then save 
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the document back to the cloud. 
 

Figure 11 - Editing an Excel Workbook in Excel Online 

Sharing Workbooks 
Shared workbook functionality allows multiple users to view and make changes concurrently to a workbook 
located in an accessible network location. For example, if your staff were working on a large project that 
required the input of several staff members, sharing the project workbook would allow them to work on the 
engagement document at the same time. Compare that to the commonly used process of using a workbook 
exclusively – while one staff member is using a workbook, other staff members are prevented from making 
changes to the same workbook. Hence, work on the project is slowed because access to the project document 
is restricted when it is being used by other staff members. 
 
In the following example, the CFO for GTM Printing has created a workbook for his office managers to enter 
budget updates for the third and fourth quarter of the current year. GTM prepares budgets annually but updates 
budgets every six months. The workbook has a separate sheet for each office, and it has been saved in a shared 
folder on a server in the home office, accessible by using some form of remote access software. The CFO wants 
to share the workbook so that managers will be able to enter their budget updates even if another manager is 
already using the workbook. From the vantage point of the CFO, periodic updates to the budget are important 
so that managers can routinely compare actual to budgeted results. To share a workbook, open the workbook 
to be shared. From the Review tab of the Ribbon, select 
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Share Workbook. In the Share Workbook dialog box, check Allow changes by more than one user at 
the same time as shown in Figure 17. On the Advanced tab, enter the number of days to maintain the 
change history. The default is thirty days. Enter an arbitrarily large number such as 3650 days to 
maintain the changes indefinitely. 

 

Figure 17 - Sharing a Workbook 
 
After a workbook is shared, multiple users can view and modify the workbook concurrently, and Excel 
automatically maintains a history of all changes made to the workbook. The change history tracks what was 
changed, who made the change, and the date and time of the change, etc. The Keep change history setting on 
the Advanced tab of the Shared Workbook dialog box determines how long the change history is maintained. If 
the history is set to be maintained for thirty days, changes made on the first day after sharing the workbook will 
be removed from the history thirty days hence. 
 
Unfortunately, not all Excel functionality is available in a shared workbook. Table 1 below lists the functionality 
that is restricted in a shared workbook, together with possible workarounds. 
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SHARED WORKBOOK FUNCTIONALITY 

Users Cannot Possible Workaround 

Create an Excel table  

Insert or delete blocks 
of cells 

Entire rows and columns can be inserted. 

Delete worksheets  

Merge cells or split 
merged cells 

 

Add or change 
conditional 
formats 

Existing formats continue to appear as cell 
values change. 

Add or change data 
validation 

Cells continue to be validated when you type 
new values. 

Create or change charts 
or PivotCharts 

Existing charts and reports can be viewed. 

Insert or change 
pictures or objects 

Existing pictures and objects can be viewed. 

Insert or change 
hyperlinks 

Existing hyperlinks continue to work. 

Use drawing tools Existing drawings and graphics can be viewed. 

Assign, change, or 
remove passwords 

Existing passwords remain in effect. 

Protect or unprotect 
worksheets or the 
workbook 

Existing protection remains in effect. 

Create, change, or view 
scenarios 

 

Group or outline data Existing outlines can be used. 

Insert automatic 
subtotals 

Existing subtotals can be viewed. 

Create data tables Existing data tables can be viewed. 

Create or change 
PivotTable reports 

Existing reports can be viewed. 

Write, record, change, 
view, or assign 
macros 

Existing macros that do not access unavailable 
features can be run, and macros can be 
recorded and stored in another workbook. 

Change or delete array 
formulas 

Existing array formulas continue to calculate 
correctly. 

Use a data form to add 
new data 

An existing data form can be used to find a 
record. 

Work with XML data  
Table 1 – Shared Workbook Functionality 

 
Note that with few exceptions, functionality incorporated into a workbook at the time it is shared is still functional 
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in the shared workbook. By anticipating the needs of users, a fully functional shared workbook can be built by 
adding the needed functionality before sharing the workbook. Also, note that all of the restricted functionality 
can be made available by un-sharing a workbook. However, any change history recorded will be deleted when 
a workbook is un- shared. 

To edit a shared workbook, simply open and modify it just as with any other workbook. Excel will maintain the 
change history in the background. In default, each user has a personal view of a shared workbook. Personal views 
maintain individual filter and print settings for each user. To use the original print and filter settings, open the 
shared workbook. From the Review tab of the Ribbon, select Share Workbook. On the Advanced tab, uncheck 
Print settings and Filter settings in the Include in personal view section and click OK. 
 
Whenever a user saves a shared workbook, any changes saved by other users during a concurrent session 
appear in the workbook. If multiple users have made changes, the changes are color-coded by user. Hovering 
the cursor over a changed cell identifies the change made, the date and time of the change, and the name of 
the user who made the change as shown in Figure 18. Changes by other users remain highlighted until the 
shared workbook is saved once again. 
 

 
Figure 18 - Changes Identified by Date, Time, and User 

 
If more than one user makes a change to the same cell or cells during a concurrent session, the second and 
subsequent users who attempt to save their changes will be prompted to resolve the identified conflicts as 
shown in Figure 19. 
 

Figure 19 - Resolving Conflicts in a Concurrent Session 
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Users can choose to accept their own changes or the changes saved by other users. All saved changes are 
recorded in the change history, regardless of whether a change was accepted or rejected during conflict 
resolution. This allows a shared workbook owner – the user who shares a workbook – to accept or reject changes 
during a review process. The owner maintains all rights for managing the workbook – an owner can remove users 
from a shared workbook, accept or reject conflicting changes made by multiple users, and un-share a protected 
workbook when all changes have been made. 
 
Changes may be tracked at any time until a shared workbook is un-shared, at which time the change history is 
removed from the shared workbook. To track changes in a shared workbook, select Track Changes, Highlight 
Changes from the Review tab of the Ribbon as shown in Figure 20. 
 

Figure 20 - Tracking Changes in a Shared Workbook 
 
In the Highlight Changes dialog box, check Highlight changes on screen and/or List changes on a new 
sheet and click OK as shown in Figure 21. 
 

Figure 21 - Displaying Changes on Screen and on a Separate Worksheet 
 
All cells containing changes that meet the criteria set in the Highlight Changes dialog box will be surrounded by a 
navy-blue border and contain a navy-blue arrow point in the upper left corner as shown in Figure 21. Hovering the 
cursor over a highlighted cell will expose a pop-up containing the name of the user who made the change, the 
date and time of the change, and the 
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nature of the change. If the number of changes is extensive, or if the changes were made over a large range in a 
worksheet or on multiple sheets, choosing to create a new worksheet listing some or all of the changes is a 
better alternative. Excel will create a new worksheet named History that will contain a chronological list of all 
changes meeting the selection criteria set in the Highlight Changes dialog box. Note that a History sheet is not 
saved when a shared workbook is saved, but an up-to-date history can be reproduced at any time. 
 
Changes may be accepted or rejected at any time, and the accept-or-reject process may be repeated as often 
as necessary. All saved changes are available for acceptance or rejection by a reviewing user. In other words, if 
three users – Tommy, Debbie, and Mac – changed a single cell, all three values would be available for 
acceptance during the review process, notwithstanding the fact that the value entered by Tommy was the value 
currently stored in the cell. Further, rejection of a change in one review does not preclude the acceptance of that 
same change in a subsequent review. 
 
To perform a review to accept or reject changes made to a shared workbook, select Track Changes, 
Accept/Reject Changes from the Review tab of the Ribbon. Enter any desired criteria in the Select 
Changes to Accept or Reject dialog box and click OK as shown in Figure 
22. Excel will step through the workbook, stopping at each cell that contains a change 
matching the selection criteria. At each stop, the Accept or Reject Changes dialog box is presented to 
allow a user to accept or reject any change previously saved. 
 

Figure 22 - Accepting or Rejecting Changes 
 
To stop sharing a workbook, select Share Workbook on the Review tab of the Ribbon. Then, uncheck 
Allow changes by more than one user at the same time on the Editing tab of the Share Workbook 
dialog box and click OK. Caution! When a workbook is un-shared, the change history is deleted. If the 
change history is important, create an up-to-date History worksheet and print it or copy it to a new 
workbook. After sharing is stopped, the history sheet may be copied back into the workbook, but the 
worksheet must be renamed because History is a reserved sheet name. To prevent unauthorized un-
sharing of a workbook, Protect and Share a workbook with a password from the Review tab of the 
Ribbon. 
 
While shared workbooks are used primarily to allow multiple users to collaborate on tasks or projects, a 
workbook may be shared for the sole purpose of enabling change tracking. In other words, a single user may 



15  C O P Y R I G H T © 2 0 1 8. R E P R O D U C T I O N O R R E U S E F O R P U R P O S E S  
O T H E R T H A N A K 2 E8 N T E R P R I S E S T R A I N I N G E V E N T I S P R O H I B I T E D  

 

share a workbook so that Excel automatically records all changes made on a large project. A user may have no 
intention of allowing other users to make changes to the project workbook but has enabled sharing just for the 
change tracking functionality. If the user enters comments for all material changes made to the workbook, the 
workbook itself becomes self-documenting. In the example shown in Figure 23, note how the system tracked the 
change but also how the comment entered by the user at the time of the change explains why the change was 
made. This functionality is very useful in a capital budgeting or business planning exercise. 
 

Figure 23 - Using Comments to Explain Why Changes Were Made 
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